only secondary configuration, no primary

Home Forums Using vSMP Foundation only secondary configuration, no primary

This topic contains 5 replies, has 2 voices, and was last updated by  Pim 3 years, 11 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #4662

    Pim
    Participant

    I finally got full access to my servers to try out ScaleMP – vSMP-5.5.295.16.free.img

    I’ve got two DELL R815 servers connected to each other with intel true scale infiniband cards ( type QLE7342( http://www.fibrechannelworks.com/QLE7342.asp ) , I burned the .img files to bootable usb sticks and loaded both the servers.

    ScaleMP free gets through the first few configuration steps and what happens then is that both boards automatically enter in “secondary” configuration.

    Then they go on configuring the backplane, but since there is no primary board, no server will start searching for the secondary boards.

    I found a screenshot on the internet, on both servers I get up to the point where it says “configuring backplane”. It doesn’t ask me for a license number.

    http://www.scalemp.com/forums/topic/query-during-installation/

    They do seem to communicate, all infiniband lights are on, and the backplane is configured only after both servers are loading scalemp at the same time.

    Any idea what I can do as a next step to get one of the servers act as primary? Is there a boot option that I can give along with the boot loader?

    Greetings Pim

    #4663

    Erez
    Participant

    Hi Pim,

    Did you set the primary node as described in section “First Boot with vSMP Foundation and System Activation” of our quickstart guide?

    “On the board you wish to designate as the primary board (referred as board in the following screenshot), press P to make that board the primary board. No action is required on the remaining boards that will become secondary boards.”

    #4664

    Pim
    Participant

    Hi Erez. The press P option never appears.

    Both are stuck after the message:

    Configuring backplane.. OK (ID: 1)

    Nothing changes even after several hours. I made sure all VM related options in the BIOS are set to “enabled”.

    #4665

    Pim
    Participant

    I retried using two Dell C6415 nodes connected to an infiniband switch.
    “Secure Virtual Machine Mode” is enabled in the bios of both nodes.

    Still I never get the “Press P” option

    When using the switch, one of the nodes has as last output:

    Configuring backplane.. OK (ID: 1)

    And the other one has:

    Configuring backplane.. OK (ID: 5)

    If I make a direct link between the infiniband cards, both backplanes go to ID: 1

    Either way, the option to set a board as primary never appears.

    Am I missing something? Do I need to connect the nodes via ethernet as well?

    #4666

    Erez
    Participant

    Hi Pim,

    You will need to burn the vSMP Foundation Free image file directly to the USB keys – no changes or edits are required (as stated in our quick start guide).

    #4667

    Pim
    Participant

    I found the solution, my mistake was that I used the windows software unetbootin to create the images, instead of “dd” from a linux shell as mentioned in the quick start quide…

    Thanks for the support!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.